Hello everyone.
In this post, I will introduce that what discovery mechanism is. Well, this is a long story. It is hard to explain in one post. I will separate it into several different posts. They are
1.b.1 : basic concept
1.b.2 : discovery by broadcast
1.b.3: discovery by Static configuration
1.b.4: discovery by DHCP and others
OK, Let us go to the basic concept of discovery mechanism. There are two steps in AP->WLC discovery mechanism
/Step 1/
Assign one IP address on AP.
/Step 2/
Find out WLC by using Capwap discovery request and Capwap discover response
// How to assign one IP address on AP//
Basically, there are also two ways, like your PC, one is assigning one static IP. The other is assigning through DHCP server.
/// Assigning the static IP on AP ///
You can use the following commands on AP
AP# capwap ap ip address 172.33.68.191 255.255.255.0
AP# capwap ap ip default-gateway 172.33.68.254
You can use the following command to confirm your setting
AP#show capwap ip config
LWAPP Static IP Configuration
IP Address 172.33.68.191
IP netmask 255.255.255.0
Default Gateway 172.33.68.254
Primary Controller 172.33.68.10
/// Assigning IP address from DHCP server ///
** Topology **
AP ---- SW3750 ---- SWCat6K ---- WLC5508
I make dhcp pool on SWCat6k
=====
ip dhcp excluded-address 172.33.67.1 172.33.67.220
ip dhcp pool vlan367
network 172.33.67.0 255.255.255.0
default-router 172.33.67.254
=====
On SW3750, I use interface Gi3/0/4 to connect AP,
=====
interface GigabitEthernet3/0/4
switchport access vlan 367
switchport mode access
spanning-tree portfast
====
And I make packet capture on SWCat6k to see how it work.
As you can see from the picture, DHCP server gives 172.33.67.231to AP in DHCP four-way handshake.
Of course, you can use "show capwap ip config" to check it.
// How to use Capwap discovery request and response to find out WLC. //
I will explain that in the next three posts,
See you next time and Good luck !!
In this post, I will introduce that what discovery mechanism is. Well, this is a long story. It is hard to explain in one post. I will separate it into several different posts. They are
1.b.1 : basic concept
1.b.2 : discovery by broadcast
1.b.3: discovery by Static configuration
1.b.4: discovery by DHCP and others
OK, Let us go to the basic concept of discovery mechanism. There are two steps in AP->WLC discovery mechanism
/Step 1/
Assign one IP address on AP.
/Step 2/
Find out WLC by using Capwap discovery request and Capwap discover response
// How to assign one IP address on AP//
Basically, there are also two ways, like your PC, one is assigning one static IP. The other is assigning through DHCP server.
/// Assigning the static IP on AP ///
You can use the following commands on AP
AP# capwap ap ip address 172.33.68.191 255.255.255.0
AP# capwap ap ip default-gateway 172.33.68.254
You can use the following command to confirm your setting
AP#show capwap ip config
LWAPP Static IP Configuration
IP Address 172.33.68.191
IP netmask 255.255.255.0
Default Gateway 172.33.68.254
Primary Controller 172.33.68.10
/// Assigning IP address from DHCP server ///
** Topology **
AP ---- SW3750 ---- SWCat6K ---- WLC5508
I make dhcp pool on SWCat6k
=====
ip dhcp excluded-address 172.33.67.1 172.33.67.220
ip dhcp pool vlan367
network 172.33.67.0 255.255.255.0
default-router 172.33.67.254
=====
On SW3750, I use interface Gi3/0/4 to connect AP,
=====
interface GigabitEthernet3/0/4
switchport access vlan 367
switchport mode access
spanning-tree portfast
====
And I make packet capture on SWCat6k to see how it work.
As you can see from the picture, DHCP server gives 172.33.67.231to AP in DHCP four-way handshake.
Of course, you can use "show capwap ip config" to check it.
// How to use Capwap discovery request and response to find out WLC. //
I will explain that in the next three posts,
See you next time and Good luck !!
No comments:
Post a Comment